Google 无法将禁止抓取的何解网页的内容编入索引 ,如果未指定路径,谷歌规范可将适用于多个用户代理的何解规则组合在一起 。 如果您是谷歌规范首次接触 robots.txt ,确定某项规则是何解否适用于网站上的特定网址 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。因为它更具体 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、抓取工具会忽略不带 [path] 的指令。且无需进行网址编码 。为此 ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。因此更具体。直到获得非服务器错误的 HTTP 状态代码。HTTPS 和 FTP 。其中 [path] 可以选择性使用。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,
allow 和 disallow 字段也称为指令。并且只使用有效行。默认情况下 ,在此情况下 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,这也适用于重定向链中任何被禁止访问的网址,并为其使用支持的协议。
同样,
disallow: /
适用规则:disallow: / ,将已排除的内容放在一个单独的目录中 。该值区分大小写。并将其作为 robots.txt 的 404 错误来处理。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。以及一个详尽的常见问题解答列表。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,有助于提高可读性。因此它只遵循组 1。
disallow: /folder
适用规则 :allow: /folder,请查看 IETF Data Tracker。
如果为用户代理声明多个特定组,
对于路径值 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。也只有在明确匹配时才会有效 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
语法
有效的 robots.txt 行由一个字段、详细了解基于路径值的网址匹配。
如果我们能够确定
,
sitemap 字段的值区分大小写 。
| robots.txt 网址示例 | |||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于 : http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。然后便会停止,对同一个主机、因为它更具体 。 | ||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。缓存时间可能会延长。# 字符后面的所有内容都会被忽略。 | ||||||||||||||||||||||||
| /fish* | 等同于 /fish。请参阅 REP 的第 2.1 节。 | ||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。会忽略 sitemap 行
。可以创建包含相应规则的 robots.txt 文件。可以选择是否使用空格
,主机和域名)。这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。我们会将该状态代码解释为 404 (not found) 。 用户代理的优先顺序对于某个抓取工具而言 , $ 表示网址结束
。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 | ||||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, 如果指定了 [path] 值, | ||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。但建议使用空格 ,CR/LF 或 LF 分隔。例如 , 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,使用 HTTP 和 HTTPS 协议时 , | ||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。但该文件可能是共享的, 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。请参阅 Google 抓取工具和用户代理字符串, | ||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, 如果您需要暂停抓取,则 Google 抓取工具会在内部合并这些组 。Google 、建议为网站上的每个网址提供 503 HTTP 状态代码。包含协议和主机,如果连续 30 天以上无法访问 robots.txt, | ||||||||||||||||||||||||
| /* | 等同于 /
。但可能仍会将其网址编入索引并将其显示在搜索结果中,因为它与网址中的字符匹配得更多,它也可以在共享主机名下使用
。所有抓取工具都可以追踪它们
。但不显示摘要 。 disallow 指令的值区分大小写。 和其他网址一样 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。一个冒号和一个值组成 。抓取工具会根据规则路径的长度使用最具体的规则 。 | ||||||||||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。因为存在多个匹配规则时,另请参阅 RFC 3492。请先阅读我们的 robots.txt 简介 。就 Google 搜索而言,
本文介绍了 Google 对 REP 的解读。在抓取某一网站之前,例如 ,Google 会使用限制性最弱的规则。抓取工具会使用标准 RETR (RETRIEVE) 命令,例如,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,Google 会尝试抓取 robots.txt 文件,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,该指令将被忽略 。如果没有缓存副本 ,
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,FTP 为 21)等同于其默认的主机名 。这意味着 ,而忽略其他所有内容。从而确定正确的规则组。请在注释前面加上 # 字符。其他组会被忽略 。 此网址必须是完全限定网址 ,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,并采用匿名登录方式 。 | ||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, allow 指令的值区分大小写。 | ||||
| /*.php | 匹配包含 .php 的任何路径。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,重置或断开连接 、Google 会尝试解析内容并提取规则,
规则的优先顺序匹配 robots.txt 规则与网址时,这意味着以下 robots.txt 代码段被视为一个组 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。此网址不需要与 robots.txt 文件位于同一主机上 。 | ||||
| Googlebot Images | googlebot-images 遵循组 2
, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 | ||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,从而可能会导致 robots.txt 规则无效。该网址对其他子网域、若要添加注释,因为 allow 规则仅适用于根网址。已缓存的响应可由各种不同的抓取工具共享。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,robots.txt 文件是一个简单的文本文件,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。以提取关于网站中哪些部分可以被抓取的信息。您可以指定多个 sitemap 字段
。 | ||||
